(worthless) Tips & Technologies

温故知新。 いえいえ "何を今更" が好きなだけです。

+Intel.CPU

BIOS の Shutdown Temperature

過日の serial と先の gimmick でようやく蓋をして実使用に供することとなった 7 機ですが早速落ちました。

操作中に突然落ち(切れ)ましたから例の強制 shutdown だと踏んでとりあえず bios の設定を一番上の 85 ℃まで上げて電源再投入。 event には 「予期せぬシャットダウン」 が残っていましたからまあ間違いないでしょう。

さて intel 的には i5/760 には " Thermal Monitoring Technologies " は具備されていない(no)ということになっていますが open hardware monitor には core 毎の温度が出てきます。 sensor は付いているけどそれ以上は組み込んでいない(or 無効にしてある)ということなんでしょうと解釈しておきます。 intel の site には古い cpu の文書は置いてない様子なので Tc(max) = 72.7 ℃ということより詳しいことは今のところ分かりません。

さて chip に熱保護が組んであるなら設定なんぞ気にすることはないんですが no と書いてあると心配になります。 世代的に無いとは思い難いんですがねえ。 その後は落ちませんけど一抹の不安のために cpu power の設定を 99 から 97 に下げましたが多分変わりはないでしょう(

そもそも bios の設定というかその温度はどこの温度なのかが分かりません。 manual にも書いてないしちょっと検索しても出てくる気配すらありません。 それで電源を落としてくれるわけですから少なくとも memory 上の program で処理しているのではなく何某かの hardware からの値に閾をかけてるハズ。 cpu から serial 読み出しとかが出来ないなら近傍温度に何某かを足している ?

謎が謎を生む中、記録を付けるために項目名を確認するのに bios 設定に入りましたがそこで現在値に目が留まり、…

65 ℃ ?

とか思いましたがすぐさま起動して open hardware monitor を動かしてみると、…

cpu(core): 48/54 ℃ (current/max)
cpu(motherboard): 49/56 ℃

でした。 起動時にチョコチョコ動いたにも関わらず、です。 普通に考えて bios 側がおかしいというか、…

気にしないことにしました。

そういえばまあ、良くあることです bios の不具合は( 。 忘れてましたよ長く離れてましたから。 その他にも install 直後の試験では cpu の power 設定を 100% にすると割と簡単に open hardware monitor 読みで 70 ℃を超えていた事とか C7 は額面上は 100w までの対応ですけど如何な heatpipe とは言えその大きさで i5-760 の 95w を排熱できるとは思っていない事とか vista 機では cpu(motherboard) は妥当な数字(50 - 60)が出ている事とか情報が錯綜してて冷静さを欠いていた、のではないかなと。

ということで次に立ち上げたら bios の版でも見てみましょうかね。 調べものをしてて見つけた coretemp という utility と Tc(max) のハナシはまた別の機会にでも。
 

過日のクロネコ

先般手に入れた P4T-E が思いのほか綺麗でちゃんと動くみたいだし i/o shield も pc97 仕様なので実用に供せる(その意義は置いといて、笑) 様子だことから、これを使うと rimm 試験ができなくなるということで、…

今更もうひとつ調達することに。 cpu/memory 付きで売りに出ていた intel 様の(あまり評判が良くない) D850MV を手に入れました。

まあ、普通に使えるようなので i/o shield も標準じゃないことからこっちを rimm 試験機に。
 

今更 P4T-E を

端末の試験ができるくらいに整理が進んだのと探していた rimm が見つかったのでちょいと試験してみました。

いくら綺麗だとはいえいえ逆に殆ど使われていないということは少なくとも 10 年以上は放置されていたと思って間違いないのでとりあえずは " 電圧処理 " をしなくてはいけません。

数に余裕のある 2.4B を挿して初回は 電源入ってすぐ切れましたがどうせソレだろうと思いすぐさま入れなおすと入りました。 が、rimm も video も挿していないのに beep が聞こえません。 " 存在しない " のは別扱いなのかと判断して rimm を挿しましたらば video が無いと怒られましたからそういうことらしいです。

難無く bios 設定に入れましたが結論から言うと manual にあった northwood の文字しか見ていなかったのと rimm(rdram) というものを使ったことが(よく知ら)無かったので暫し紆余曲折することに。

深く考えずに設定して再起動したらいきなり beep 。 長音 3 回ですから memory ですけど身に覚えがありませんてば(

これ、基本的には fsb = 400mhz 専用なんですね。 1.7ghz の celeron を持っていましたのでそれほどには悩まずに済みましたけど。

で、fsb = 533mhz の 2.4B を挿すと倍率は x18 になっているので読み出している様子、ここに rimm の clock 設定を auto のままで cpu を overclock で base: 133mhz にすると rimm 設定が " out of range " になってしまう、というのが原因だった、と。

しょうがない celeron でと思って放置中に 「 もしかして ? 」、と思って rimm 設定を x3 固定即ち 133mhz x3 にしたらちゃんと動きましたからそういうことらしいです。

おー大発見と思いきやその後で kakaku.com の当該口コミを見てましたらば同じ事をしている方が(

何だかんだで 1.5 時間くらい通電したところで終わりにし最後に触診で温度を。 north (の heatsink )はぬるい(32 ℃ あたり )ぐらいで cpu fan の風の流れが少しあれば殊更には冷却は考えなくてよさそうです。 south は冷たいままでした、まあ、何も繋いでいませんから殆ど働いていませんけど。 手に入れたときに少し " 気配 " があったケミコンがそこはかとなく症状が進んだ気がします。 ケミコンの温度で室温以上になっていた、

CE7/14/17, CE48 -- ぬるい(33 ℃ あたり

これはまあ役柄上で普通だと思いますが、

CE47 -- 温かい(39 ℃ あたり

これだけ突出しているのが気になります。 まだ回路を追いかけていないので妥当性の判断とかケミコン交換とかは後日に。

今日はそんなところで。 
 

推定無罪

結論(と思しきこと)だけ書くと、落ちるのは bios 設定の cpu shutdown 温度(或いはそれを何某かの式で処理した値)に達したからということらしい。 発生状況からはそれが辻褄が合います。

とりあえず w7 では落ちないようにできましたが、それが正しいのか否かは不明です。 とにかく w7 それ自体の大問題というわけではなさそうなので後はボチボチ考えてみる(一旦保留)ことにしました。
 

誰が悪い ? (笑

いや、いいんじゃないの 12 に吊って。 (昨日の続き

電源入れた状態で open の sense 入力には 10v ほど出てました。 12  は 12V くらい。 昨日 sense と 12 の間の直流抵抗を測ったら 4k くらいでした。 10:1 probe ですから neg れる範疇なのに 10V に落ちる理由が分からないというか単純に 392 とか 432 で吊ってあるわけじゃないということなんでしょうな。

あーもー、図面があるとこんなに苦労しなくて済むんだけどなー。

起こすためには外さなきゃだし。

そんで CoolerMaster 挿すと天辺が 5V くらいの波形になるのよ。 でも fan の sense 出力と 12 の間の(dmm 的)直流抵抗は 4M くらいあるから open drain では、あると思う。

ネタ集めに試しに sense 入力を 2.2k で gnd に落としてみたらば、…

4.3V ≒ 4k - 2k の分圧

少なくとも sense 線を外側で吊る必要は無い様子。 んじゃもひとつネタ集め。 CoolerMaster の出力を 24k(そのへんにあったから使っただけで base 電流的には抵抗値が小さ過ぎます念のため) で 12 に吊って npn trs で反転(duty 50% だから反転しようが同じこと)し open collector のまま sense 入力に接続。 これで出るハズ。

System2 Fan     934 RPM

ハイハイやっぱりね ♪ sense 入力端で振幅は 10V くらい(これも予想通り)。
んー、…

ソレを調べるには電源の函を開けないとできないから後日というか保留にするけど fan の sense 出力線から 12 に流す向きに保護(何の ?) diode が明示的にでも寄生でも入っていると今回のような clamp 動作になる、ハズ。

計数のための threshold を低めにしておいてくれたなら悩まずに済んだという意味では Biostar が悪い、のか ?

他にも例が出てきそうだから clamp 対策 adapter を作っておくことにしよう。 4k を gnd まで落とすには 3m 流せばいいから、hfe を 100 とするなら base には 30μ 流せばいい。 ブレを見込んでこの倍を流すとして抵抗は 220k(E6 から選定) で okay 。

んじゃ部品集めてそのうちに。
 

あら勘違い

アナタ背面の 3.5mm jacks のうち少なくとも line out はズッと前から stereo で使ってたくせに 3 個クチがあれば 6ch 出力が(可/不可で言えば)可能だことに思いが馳せなかった訳ェエ ?

ええ、3 個クチだと 5.1ch どころか 4.1ch すら無理だと思い込んでました。

今は向きも含めて切り替えられるのよね、…

どえー、恥ずかし。
 

今日のミアンダ

何かを漁りに出掛けたわけではないんですけど本来の調達要件が頓挫したので嗚呼また仕事が遅れるぢゃないかもーと思いつつ何か買いでもしないと収まりが悪くて( ...


近所の "a" に新しい junk 置き場が出現していたのですかさず VL の video と ide 。 それぞれ ¥100.- 。 あと PCI 初期と思しき mlb 。 これも ¥100.- 。


今更どこから出てきたのよ的。


他にもいろいろあったけど video は chip が手持ちの 805 より速そうな 864 だったから。 ide はウチには 1 枚しかなかったから。 mlb は時代感と、珍しい simm が載ってたから。 他は ... 今更感なので放置(


帰ってよくよく mlb を見てみると jumper だらけ。 まあ当時はそんなもんだったわけだけどこれこの状態で動いたとしてその後わかんないなあ手元にある同時代のやつでも参考にするかと思いつつ唯一の手がかり "433 Ver4.0" を検索すると ...


どうやら SHUTTLE HOT-433 らしい。 使ってた方のサイトを見つけました。 嗚呼、合掌。


動作確認はボチボチで。



後記: 数時間後

とはいえ気になるので簡単な check だけ。 pci video 挿して at の電源繋いでホイっ。

何も出ません ...
さてどこまでやるか、...

とりあえず ↑ で見つけた junper list を追っかけてみることにする。 cpu の heatsink を外すと Am5x86 でした。 socket3 = 486sx/33 の感覚だったのでちょと驚いたけどそういえばそんな時代(ちょっとでも速く)でしたかねえ。

で、設定の確認をして行くと合ってる合ってる ... あれッ、base が 40mhz になってるし電圧も上げてある。 ふむふむ、何かしようとしてたのかソレで使ってた(今挿した pci video が 40mhz に耐えなかったから動かないように見えた)のか。

とりあえず normal にして、...

出ました ami の graphical bios setup 画面。 懐かしいねえ、私はあまり好きじゃないけど。

あーあ、動いちゃったよ、笑)
んじゃ、何に使うかはボチボチで。

 
記事検索
最新コメント
QRコード
QRコード
プロフィール

Nas

  • ライブドアブログ